Overview
The GFI LanGuard Attendant service (lnssatt.exe) will not start with the error 1067, and the dashboard fails to load with an 'invalid license' error.
Diagnosis
The symptoms above usually indicate the problems with the data file lnss.dta, containing encrypted passwords. Corruption of this file generally happens when the hard disk of the GFI LanGuard machine runs out of space or if the Microsoft SQL database that handles the scan results exceeds the threshold of data or log file size.
To address the root cause:
- Check the remaining space on the hard disk - if it is nearly full, free the space or consider moving the GFI LanGuard to the new server.
- Verify whether the SQL database is purging log files. Keep the size of the database log files small by implementing one of the following:
- Configure full backups on the database. This will shrink the log file to a few MB every time the backup runs
- Periodically run a shrink job on the database (or just the log file).
To remedy the lnss.dta corruption follow the solution steps below.
Solution
- Stop the GFI LanGuard Attendant Service if it is running.
- Close any running GFI LanGuard application windows.
- Open Windows task manager and terminate any running processes called update.exe.
- Open the GFI LanGuard application data folder, the default location is
C:\ProgramData\GFI\LanGuard 12\
. - Make a backup copy of the file lnss.dta.
- Download http://ftp.gfisoftware.com/support/LNSS/Scripts/lnss.zip.
- Check the Properties of the file and click the Unblock button if present.
- Extract lnss.dta from the ZIP file and place it in the folder mentioned above.
- Start the GFI LanGuard Attendant service.
Note: After performing this procedure you will have to re-enter any passwords you have set within the GFI LanGuard.
Testing
Check that the GFI LanGuard Attendant service is running, launch the LanGuard console, and verify that the error message is gone. If the issue persists, the root cause might be local environment settings problem. Restore the backed up lnss.dta and troubleshoot based on the corresponding service start errors in the Windows Events logs.