Overview
After installing Central Management Server (CMS) the synchronization fails and the GFI LanGuard console shows the error:
Error encountered while synchronizing: Error status 'ProtocolError', message 'the remote server returned an error: (500) Internal server error.'
Also, when opening the Web console the following error is displayed:
HTTP error 500.19 with the error code 0x8007007e
Another web page, usually WSUS, is also hosted on the IIS and propagates incorrect settings to other web sites.
Prerequisites
An account with Administrator Privileges.
Diagnosis
Error 0x8007007e translates as ERROR_MOD_NOT_FOUND - The specified module could not be found.
CMS runs using Microsoft IIS and this problem usually occurs when WSUS (or web page with similar behavior) is hosted on the IIS. The XPress compression scheme module (suscomp.dll) gets installed with WSUS and the schemas are defined globally. They try to load in every Application Pool, regardless of whether it is 64-bit or 32-bit. Such behavior results in an error when 64-bit version of suscomp.dll attempts to load in an Application Pool which is running in 32-bit mode.
To verify the issue:
- Go to C:\Windows\System32\inetsrv\config\.
- Open the file applicationHost.config with a text editor.
- Find the entry:
<scheme name="xpress" doStaticCompression="false" doDynamicCompression="true" dll="C:\Windows\system32\inetsrv\suscomp.dll" staticCompressionLevel="10" dynamicCompressionLevel="0" />
Solution
Remove/Disable the XPress compression scheme from the configuration following these steps:
- Open a command prompt running as administrator.
- Run the following command:
%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /-[name='xpress']
- Type IISreset and press Enter.
More information can be found at https://blogs.msdn.microsoft.com/webtopics/2010/03/08/troubleshooting-http-500-19-errors-in-iis-7
Testing
Once the IIS configuration is fixed and Application Pool restarted, perform the steps below:
- Restart the GFI LanGuard Services.
- Open the Web console.
- Open the Languard console and force the sync by running a scan on the server itself.