Overview
This article provides information on how to enable debug logging in GFI LanGuard.
Diagnosis
By default, debug mode is now enabled in GFI LanGuard. However, if you disabled it in the past, for troubleshooting purposes, it may be necessary to temporarily enable it.
Solution
From the GFI LanGuard console, click the menu button on the top left and navigate to Help > Enable debug.
Note: If the Enable Debug option is grayed out, this means Debug mode is already enabled.
If the console is inaccessible, or on the Agent machine, you can enable Debug mode using the Registry Editor instead:
- If the machine is GFI LanGuard Server - close the GFI LanGuard UI (console).
- Stop the GFI LanGuard Attendant Service.
- Press Windows + R keys together to open the Run dialog box.
- Type
services.msc
and press the Enter key. - Locate and stop the GFI LanGuard Attendant Service.
- Open the Registry Editor (Start > Run > type
Regedit
and press Enter). - In the Registry Editor, browse to the following key:
- For 32-bit installations:
HKEY_LOCAL_MACHINE\SOFTWARE\GFI\LNSS<version number>\Config
. - For 64-bit installations:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GFI\LNSS<version number>\Config
.
- For 32-bit installations:
- Change the DWORD value for
Debug
to1
. - Add/modify the key
multifilebackupcount
, and set it to a decimal10
(or the value requested by Technical Support).
To add:- In Registry Editor, do either of the below:
- Navigate to Edit > New from the top menu.
- Right-click (on some blank space) in the Registry Editor and choose New.
- Under the New menu, choose DWORD (32-bit) Value.
- Type
multifilebackupcount
for the name.
- In Registry Editor, do either of the below:
- Close the Registry Editor.
- Restart the GFI LanGuard Attendant Service stopped in step 2.
Testing
Navigate to the LanGuard debugging log files location, typically C:\ProgramData\GFI\LanGuard 12\DebugLogs, to confirm that logs are being written.
Note: If you wish to disable debugging - set Debug
to 0 in the procedure above).