Overview
When a computer has multiple IP addresses assigned, an Agent scan can return a non-desired IP address to GFI LanGuard. This article provides information on how to configure an Agent to return a specific IP address to GFI LanGuard.
Diagnosis
When the Agent machine has multiple IP addresses, the Agent automatically selects the IP address to use and an Agent scan can return a non-desired secondary IP address to GFI LanGuard. If the returned IP belongs to a cluster, a load balancing system, a NIC teaming entity, or is part of another VLAN, it might be beneficial to manually specify which IP is being returned by the Agent to the GFI LanGuard server.
It is possible to configure the Agent to return the desired IP address, following the steps described in the Solution section.
Solution
- Connect to the Agent computer.
- Open the Agent installation path:
- 64-bit:
C:\Program Files (x86)\GFI\LanGuard 12 Agent\
- 32-bit:
C:\Program Files\GFI\LanGuard 12 Agent\
- 64-bit:
- Create a file with the name:
localip.txt
- Open the file created and type the IP which needs to be listed in the GFI LanGuard console.
- Create the same file in the data path:
C:\ProgramData\GFI\Languard 12\
- Perform the same steps on each Agent computer with the same issue.
Note: The localip.txt file contents should be just a single IP address, not a list, range, or CIDR notation.
Testing
Wait for the next scheduled Agent scan or start an Agent scan manually from the Dashboard -> Overview tab click on Scan Now link in the Agent Status section.