Overview
After changing the Database Backend in the GFI LanGuard console, agents no longer appear in the Dashboard.
Environment
GFI LanGuard
Root Cause
Agents and Target Devices of Scan are stored in the Database Backend of GFI LanGuard with scan results. When the Database Backend is changed, all scan results and agents are no longer present in the Configuration because they are stored in the previously used database.
Resolution
There are three possible solutions for this issue:
Solution 1
- Add computers from the Dashboard > Common Tasks > Add more computers.
- Right-click on the Organizational Node in the Dashboard and select Network Discovery.
- Select Run now.
Solution 2
- Go to the GFI LanGuard Console > Configuration > Agents Management.
- Select Deploy Agents to deploy agents on target machines.
NOTE: If agents are already deployed, they are detected and added in the GFI LanGuard console.
Solution 3
Reconnect to the previously used Database Backend.
NOTE: If the previous database is at maximum capacity, it would not be advisable to attempt to reconnect.
- Max Size for a SQL 2005 Express Edition database is 4GB.
- Max Size for a SQL 2008 R2 Express or later database is 10GB.