Overview
When deleting Scan Results from GFI LanGuard, the following error is displayed:
Some Scans were not deleted due to database integrity restrictions!
Possible solution: Delete the computer instead.
Diagnosis
In GFI LanGuard, a computer snapshot - the information about a computer at a specific moment - may be composed of the results from more than one scan. For example, you could run a Missing Patches scan and then a System Information scan. The computer snapshot composes info from those two scans, each covering a certain specialized area.
That error message above shows up when you try to delete a scan that is a contributor to the snapshot of a computer. Once a new scan brings fresh data, the old scan can be deleted.
Solution
Note: If the Scan Result contains multiple targets, any one of these can be the reason for the error. Try to determine the most probable candidate, or apply the solution to the whole range of target machines.
There are two possible solutions:
Solution 1
- Run a Full Scan on the machine member of the Scan Result.
- After this, you should be able to delete the previous Scan Results.
Solution 2
- Remove the machine from the GFI LanGuard console.
- Delete the Scan Results in question.
- Add the machine in GFI LanGuard again.
As long as you are not interested in the machine scan history this solution takes less time.
Warning: When a computer is deleted, any scan results associated with it will be removed. This action cannot be undone.