Summary
Agent Diagnostics is failing with error ping check failed (error code: 11001 - no such host is known) or destination host is unreachableOverview
ENVIRONMENT
- LanGuard 12.4 build 20180706
PROBLEM
- New agent installation is failing at agent diagnostics check with error destination host unreachable and/or ping check failed
ERROR
- (error code: 11001 - no such host is known)
Cause
- The newly installed agent is unable to communicate back with GFI LanGuard since the hosts file on the webservers or clients has an entry that points back to themselves
Workaround
- Remove the entries in the hosts file on the webserver or on the client computer that is pointing back to themselves
- Navigate in path C:\Windows\System32\drivers\etc\hosts
- Copy the hosts file on the desktop
- Open the hosts file on the Desktop with notepad
- Remove the entries (hostnames, IPs) that are pointing to their own IP addresse(s) and/or hostname(s)
- Replace the edited hosts file back in path C:\Windows\System32\drivers\etc\hosts replacing the old hosts file
- Remove the LanGuard agent manually from the webserver or the client computer
- Open the command prompt running as administrator
- Run the following command: MsiExec.exe /X{160301DE-306A-4ADE-8A47-BC5790AF0486}
- Reboot the machine
- Install the agent newly from the GFI LanGuard dashboard
Resolution
- Removing the hostnames and IP addresses from the hosts file that are pointing to them selves, removing the agent manually and reinstalling will resolve the issue with agent communication
Additional Information
Corresponding support article
- Uninstall the GFI LanGuard agent manually
https://www.gfi.com/support/products/how-to-manually-remove-a-gfi-languard-agent
- Deploy automatically agents in GFI LanGuard
https://manuals.gfi.com/en/languard/content/acm/topics/managing_agents/deploying_agents.htm?Highlight=install%20agent