Overview
The synchronization fails with the newly installed Central Management Server (CMS) and the GFI LanGuard console shows the following error:
Connecting to server '<server_name>:1077' failed with error: 'Internal Server Error'
When opening the Web console the following error is displayed:
HTTP error 500.19 with the error code 0x800700c1
Another web page, usually WSUS, is also hosted on the IIS and propagates incorrect settings to other web sites.
Prerequisites
An account with Administrator Privileges.
Diagnosis
CMS runs using Microsoft IIS and this problem usually occurs when WSUS (or web page with similar behavior) is hosted on the IIS. DynamicCompressionModule and StaticCompressionModule are installed by WSUS globally and propagate to other web sites. They try to load in every Application Pool, regardless of whether it is 64-bit or 32-bit, resulting in HTTP Error 500.19 - Error Code 0x800700c1 for sites running in 32-bit mode.
SOLUTION
Check in the "C:\Windows\System32\inetsrv\config\applicationHost.config" for the following entries within the <modules>:
- <add name="DynamicCompressionModule" lockItem="true" />
- <add name="StaticCompressionModule" lockItem="true" />
- Add a precondition attribute (preCondition="bitness64") for these module entries so that they load only in 64bit application pools, i.e.:
- <add name="DynamicCompressionModule" lockItem="true" preCondition="bitness64" />
- <add name="StaticCompressionModule" lockItem="true" preCondition="bitness64" />
- Open a command prompt running as administrator.
- Type IISreset and press Enter.
Testing
Once the IIS configuration is fixed and Application Pool restarted, perform the steps below:
- Restart the GFI LanGuard Services.
- Open the Web console.
- Open the Languard console and force the sync by running a scan on the server itself.