Overview
When the agents have issues with getting patches or updates from the GFI LanGuard server or the Relay it is possible to manually test if the files can be accessed from the agent machine.
Diagnosis
Users can use the following two procedures to test if an agent can download files from the GFI LanGuard server or via a Relay Agent.
Solution
A. Downloading from the GFI LanGuard Server
Use the following procedure to test if an agent can download updates from the GFI LanGuard Server:
- Log in to the agent computer.
- Open Microsoft Internet Explorer.
- Enter the URL as follows:
http://LanguardServerIP:Port/files/update/FileName
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Examples:
- http://192.168.1.54:1072/files/update/lanss_12_2_patchmngmt.7z
- http://192.168.1.54:1072/files/update/wsusscn2.cab
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Examples:
- You should receive the pop-up to save the file. Click Save and make sure the file downloads successfully.
Note: The critical file to test for patch definition updates is the wsusscn2.cab file.
Note: The file names to use for the test are any files located in the LanGuard server's update directory:
64 bit: C:\ProgramData\GFI\LanGuard XX\Update\
B. Downloading via a Relay Agent
Use the following procedure to test if an agent that is assigned to use a relay can successfully download update files:
- Log in to the agent computer.
- Open Internet Explorer.
- Go to Tools > Internet Options > Connections > LAN Settings.
- Check the Use a proxy server for this LAN option and uncheck all other options.
- Add the Relay Agent IP and Port (these can be found in the LanGuard console > [Relay Computer] > Properties > Relays tab > Advanced Settings).
- Enter the following URLs to test downloading:
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http://go.microsoft.com/fwlink/?LinkID=74689
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http://software.gfi.com/lnsupdate/lanss_12_patchmngmt.7z
(second link if working with LanGuard 12)Note: Although these URLs are internet URLs, the relay agent recognizes them and either download the file from the GFI LanGuard server to its cache or serve the file directly from its cache.
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- You should receive a pop-up to save the file. Click Save and make sure the file downloads successfully.
- After completing the test, reset the proxy settings in Internet Explorer to their original state.
Testing
The successful download indicates that the agent should be able to download updates GFI LanGuard Server or via a Relay Agent without problems