Overview
GFI LanGuard failed to install or upgrade correctly, or become corrupted, and some of the following errors appear:
- Console and Services do not start or unexpectedly stop
- Tasks and Program Updates fail
- Console tabs do not update the information or results of the scan/remediation jobs
- Constant exceptions and crashes in logs
- Components not registered or missing files, for example, "The scanning profiles database is not available"
- The Computer tab is blank after an upgrade
This article provides guidance for repairing LanGuard.
Diagnosis
If you are experiencing problems only with scanning or remediation operations, first Test Network Connectivity and Security Permissions for GFI LanGuard Operations and check our Knowledge Base for the specific errors you encounter, like GFI LanGuard Agent Install or Remediation Job Status Stuck at Pending.
If you are experiencing problems with program updates or scanning operations not detecting expected patches, it may be that your LanGuard version is old - updated definitions are only provided to the latest versions of the product. Therefore it is recommended to always upgrade to the most recent version.
The most common root cause for the failed installations or upgrades is not meeting all the installation prerequisites and system requirements. For example:
- not unblocking the installer
- not disabling antivirus software before the deployment
- using an account with not enough local administrative privileges.
As for the already running installation, it is possible for components to become corrupt due to changes in the environment.
The recommended solution for fixing the GFI LanGuard broken installation or corrupted components is using the Repair option in the Programs and Features applet (in the Windows Control Panel).
Prerequisites
- Ensure that the machine where GFI LanGuard is going to be repaired meets the system requirements.
- Configure the firewall to allow GFI LanGuard to connect to GFI servers and to the remote machines to be monitored.
Solution
To repair the GFI LanGuard installation:
- Log on to the GFI LanGuard server as an Administrator or user with administrative privileges.
- Disable any present antivirus(es) until the repair procedure is completed (Windows Defender is an antivirus too).
- Save any pending work and close all open applications.
- Download the installer for the currently installed GFI LanGuard version
- Right-click on the installer > Properties > Unblock > Apply before running the installation.
Note: if the "Unblock" option is not present, move on to the next step. - Double-click on the LanGuard installer to run the installer and wait for the first wizard windows.
- Go to the
Temp
folder created – typicallyC:\Users\<logged on user>\AppData\Local\Temp\LanGuard12Resources
orC:\Users\<logged on user>\AppData\Local\Temp\2\LanGuard12Resources
. - Copy this folder to the desktop and cancel the installer.
- Run the Repair option from Programs and Features in Control Panel and point the repair to the folder that was copied in the previous step.
If you are not using the latest LanGuard version, once LanGuard is fixed it is recommended to upgrade to the most recent version.
For the failed initial LanGuard deployment with no configured settings to lose it is recommended to run the fresh installation instead.
Testing
Run the GFI LanGuard and check the operations that were failing before.
Or, if this is your first installation, GFI LanGuard will automatically start a scan of the local computer for vulnerabilities when launched for the first time. On completion, the GFI LanGuard Console Home page displays the vulnerability scan result.
If the corruption issues still remain it is recommended to backup the GFI LanGuard and run the fresh installation using existing backend DB.