Overview
GFI LanGuard is unable to scan devices behind the NAT (Network Address Translation) router.
Root Cause
GFI LanGuard is unable to resolve the public IP address to the private IP address of the client hostname that is residing behind the NAT router.
Resolution
Scanning a computer behind the NAT router is not supported since GFI LanGuard scans the public IP address and is unable to find and locate the hostname residing behind the NAT router.
For GFI LanGuard to be able to scan the client computer successfully, it requires scanning the IP of the client computer for gathering the client information. The client can either be joined to a domain or a workgroup.
- Domain Environment: The client must resolve the hostname to the IP address.
- Workgroup Environment: The client must be ping responsive to gather data.
NOTE: A VPN connection allows connecting to the same network segment or to a domain environment.
Related Articles
- Resolving Domain Names Using DNS Lookup in GFI LanGuard
- Testing Network Connectivity and Security Permissions for GFI Software Security Products
- Recommendations for Performing Scans over a Slow Network Connection