Overview
While checking for Program Updates, the updates are downloaded successfully; however, the following error displays during the installation process.
Unable to install updates.
This error is usually caused due to old updates. This article explains how to clear the old updates to download a fresh copy. To perform the process, you can choose one of the following methods:
Information
Environment
- GFI LanGuard 2012 and higher.
Root Cause
The most common root cause of this error is that there is no sufficient drive space available for the updates.
Process
Method 1: Step-By-Step Instructions
- Make sure the Scanning Profiles Editor is not open.
- Go to Start > Administrative Tools > Services.
- Stop the GFI LanGuard Attendant Service.
- Delete all the files except the following in the Update folder:
C:\ProgramData\GFI\LanGuard 12\Update\
DO NOT delete the entire Update folder and the files below:
- updatehistory.xml
- saccess.sql
- ssqlserver.sql
- toolcfg_maintenance_90.xml
- toolcfg_maintenance_102.xml
- toolcfg_maintenance_103.xml
- toolcfg_maintenance_104.xml
- toolcfg_maintenance_110.xml
- toolcfg_maintenance_111.xml
- toolcfg_maintenance_112.xml
- Start the GFI LanGuard Attendant Service in the Services window.
- On the GFI LanGuard console, go to: Configuration > Program Updates > Check for updates > Next.
- Select the option Update ALL files (including the ones already updated) on the bottom left corner.
- Click Next.
- Wait for the process to complete and press Finish.
- Restart the GFI LanGuard Attendant Service.
- Go to Activity Monitor > Program Updates Activity to check the last update information to confirm no errors.
Method 2: PowerShell Instructions
- Open PowerShell as an administrator on the GFI LanGuard server.
- Right-click on Windows PowerShell > Run as administrator.
- Once open, make sure the title bar displays: Administrator: Windows PowerShell
- Run the following commands:
-
Get-process *scanprofiles*|stop-process -force
-
Get-service *lanss*|stop-service -force
-
Get-ChildItem -Path 'C:\ProgramData\GFI\LanGuard 12\Update'-Recurse -Exclude updatehistory.xml,msaccess.sql,mssqlserver.sql,toolcfg_maintenance_102.xml,toolcfg_maintenance_103.xml,toolcfg_maintenance_104.xml,toolcfg_maintenance_110.xml,toolcfg_maintenance_111.xml,toolcfg_maintenance_112.xml,toolcfg_maintenance_90.xml|Remove-Item -Force get-service *lanss*|start-service
- On the LanGuard console, go to Configuration > Program Updates > Check for updates > Next.
- Select the option Update ALL files (including the ones already updated).
- Wait for the process to complete and press Finish.
- Run the following command to restart the service:
get-service *lanss*|restart-service -Force