Overview
When launching any type of scan from the GFI LanGuard console, this fails after a couple of seconds. When the scan is launched from the Scan tab, the scan starts, but after a few seconds, the following error appears:
Scan was stopped by the user!
Environment
- GFI LanGuard
- Any SQL Server Express version
Root Cause
This error is displayed by GFI LanGuard when the database backend is full, and no more data can be written to it. SQL Server Express Edition 2008 has a limit of 4GB. In the R2 update, this was extended to 10GB.
If the database backend is migrated, you would need to re-configure GFI LanGuard to point to the new SQL server: Changing the GFI LanGuard Database Backend
Resolution
Upgrade SQL Server Express to the full version or upgrade to a SQL Express version with greater capacity. Microsoft SQL Express 2008 R2 and newer extended the limit to 10GB.