Overview
After running a scan using the Missing Patches profile, the below error message is displayed in the Scanner Activity window:
Expression too complex
Root Cause
The operationsprofiles.mdb was corrupted and needed to be replaced.
Resolution
Try to Compact & Repair the operationprofile.mdb:
- Browse to the folder:
- \Documents and Settings\All Users\Application Data\GFI\LANguard 11 (Windows 2003/XP)
- \ProgramData\GFI\LANguard 11 (Windows 2008/7)
- Open the operationsprofiles.mdb in Microsoft Access.
- Compact & Repair the database.
If the issue still persists, replace the operationsprofiles.mdb with a clean copy of another GFI LanGuard installation:
- Stop the GFI LanGuard Attendant service.
- Browse to the folder:
- \Documents and Settings\All Users\Application Data\GFI\LANguard 11 (Windows 2003/XP)
- \ProgramData\GFI\LANguard 11 (Windows 2008/7)
- Rename the original operationsprofiles.mdb to operationsprofiles_old.mdb
- Copy the new operationsprofiles.mdb to the current folder.
- Start the GFI LanGuard Attendant service.