Answer
Problem
After starting agent diagnostics it is failing at step 1 Checking connection with the agent with error code 2202
Environment
- GFI LanGuard
- All supported platforms
Solution
Add the account that is running on the GFI LanGuard server for GFI LanGuard Attendant service on the client machines Local Security Policy to Log on as a Service.
- Go to Start > Run and type secpol.msc and press Enter.
- Expand Local Policies.
- Select User Rights Assignment.
- Scroll down till you see Log on as a service.
- Right-click it and go to Properties.
- Click Add User or Group and add that account there.
- Click Apply and OK and close out of the Local Security Policy.
- Apply the changes.
- Open a command prompt and type GPupdate /force and press Enter.
Cause
The account used for authentication with the agent has insufficient rights on the client machine.