Overview
GFI LanGuard enables users to configure various additional agent settings, including general operation options, data transfer, and update timeframe. This article explains the available additional settings and how to modify them.
Diagnosis
Agents enable faster audits and drastically reduce network bandwidth utilization. It is recommended to verify the default agent settings and modify them if needed.
Note: Refer to Configuring Agent Properties for the information on how to configure various properties per agent, including authentication method, credentials, attributes, etc.
Solution
To configure additional agents’ settings:
- Click the Configuration tab > Agents Management.
- Click Agents Settings.
Warning: Communication on a chosen TCP port (1072 by default) must be enabled in the Windows firewall for GFI LanGuard Agents to send data to GFI LanGuard.
- Configure the options described below:
Option Description Auto uninstall Set the number of days after which GFI LanGuard Agents automatically uninstall themselves if the host computer is unresponsive for the set period of days. Agents report using Configure the port and IP address used by agents to communicate and report status to GFI LanGuard. When the GFI LanGuard machine has multiple IP addresses and the Default setting is selected, GFI LanGuard automatically selects the IP address to use. - Specify the timeframe in which agents are allowed to download updates.
- Click OK to save and close the dialog.
- (Optional) Click the Advanced tab and select Create a temporary custom share. When this option is enabled and administrative shares are disabled on agent machines, GFI LanGuard creates a temporary shared folder for transferring information.
- Click OK to save and close the dialog.
Testing
The configured settings take place immediately after the dialog is closed, no additional testing is required.