回答
問題
GFI LanGuardのコンソールが、何もエラーメッセージを表示せずにハングアップします。イベントビューア - アプリケーションログを参照すると、エラー (1002) : "The program LanGuard.exe stopped interacting with Windows and was closed(プログラムLanGuard.exeがWindowsとのやりとりを停止し、閉鎖されました。)" が表示されています。
"lanss_v114_dashboard.csv"のログを見ると、次のようなエラーがあります。
"error ", "CrmiModule", "Given DB connection is null."("エラー""Crmiモジュール""該当DB接続はnullです。")
環境
- GFI LanGuard 2012 とそれ以降のバージョン
- GFI LanGuardはSQLデータベースを使用している
解決策
サーバーにログインしているユーザーが、SQLデータベースへのアクセス権を持っていることを以下の手順で確認してください。- ファイルエクスプローラーを開き、表示→ファイル名の拡張子を有効にしてください。
- デスクトップに空のドキュメントを作成し、右クリック>新規作成>テキストドキュメントを選択してください。
- 新しいテキストドキュメントの名前を変え、拡張子を.udlに変更し、ダブルクリックで開いてください。
- GFI LanGuard で構成した設定に応じて、Windows 認証または特定のユーザー名とパスワードを使用して、SQL DB への接続テストをしてください。
- 接続に失敗した場合は、SQL サーバーのトラブルシューティングを行ってください。
- GFI LanGuard の設定ファイル(通常はC:\ProgramData\GFI\LanGuard 11にあります)に移動してください。
- toolcfg_database.xml という名前の XML ファイルを開いてください(右クリック > 編集)。
- キーを探してください: <Option Name="DbType"><![CDATA[1]]></Option>を選択し、CDATAの値を[1]から[0]に変更してください。
- GFI LanGuardのデータベースタイプがSQLからAccessに変更されます。
- コンソールを次の場所に移動してください。 設定> データベース メンテナンス オプション> データベース バックエンド設定...
- SQL データベースを再接続してください。
- 通常はこれで問題は修正されているはずです。
原因
GFI LanGuardコンソールが起動すると、プログラムデータ/GFIにあるXMLファイルからすべての設定を取り出し、設定されたデータベースへの接続を開始します。通常、GFI LanGuardは、データベースが破損していて修復が必要な場合を除き、データベースへの接続エラーを表示します。