概要
GFI LanGuard コンソールでデータベースバックエンドを変更した後、エージェントがダッシュボードに表示されなくなりました。
環境
GFI LanGuard
原因
スキャンのエージェントとターゲットデバイスは、スキャン結果と共にGFI LanGuardのデータベースバックエンドに保存されます。データベースバックエンドを変更すると、すべてのスキャン結果とエージェントは以前使用していたデータベースに保存されるため、設定から見えなくなります。
解決策
この問題に対しては、3つの解決策があります。
解決策 1
- ダッシュボード > 共通タスク > コンピュータの追加からコンピュータを追加してください。
- ダッシュボードで組織ノードを右クリックし、Network Discovery(ネットワーク・ディスカバリー)を選択してください。
- 今すぐ実行を選択してください。
解決策 2
- GFI LanGuard コンソール > 設定 > エージェント管理 に移動してください。
- エージェントの展開を選択して、ターゲットマシンにエージェントを展開してください。
注意: エージェントがすでに展開されている場合、GFI LanGuard コンソールで検出され追加されます。
解決策 3
以前使用していたデータベースバックエンドに再接続してください。
注:以前のデータベースが最大容量に達している場合、再接続を試みることはお勧めしません。
- SQL 2005 Express Editionのデータベースの最大サイズは4GBです。
- SQL 2008 R2 Express以降のデータベースの最大サイズは10GBです。