回答
問題
GFI LanGuardは、Microsoft SQLデータベースにデータをロード/保存しようとすると、エラーが発生することがあります。 この場合、2つのログに'timeout expired'と表示されます。
lanss_vXXX_configtools.csv:
..."error ","CommonUtils","GenericDbConnection.GetDataSet - Error System.Data.SqlClient.SqlException (0x80131904): タイムアウトが発生しました。操作の完了前にタイムアウトが発生したか、サーバーが応答していません。
lanss_vXXX_reporting.csv:
..."error ","Exporter","ExportScanResultsFromDatabase::ExportToXmlFile COM error HRESULT '-2147217871' メッセージ 'IDispatch error #3121' source 'Microsoft OLE DB Provider for SQL Server' 説明 'Timeout expired'."
..."info ","Exporter","ExportScanData scanSessionID '92926029' filename 'D:\GFI Languard Scan Results\Aug 2017\scanresultxml_Desktop Scan.txt_2017_08_03_145414.xml' result '-2'<<"
..."error ","Exporter","ExportScanResultsFromDatabase::ExportToXmlFile COM error HRESULT '-2147217871' メッセージ 'IDispatch error #3121' source 'Microsoft OLE DB Provider for SQL Server' 説明 'Timeout expired'."
..."info ","Exporter","ExportScanData scanSessionID '92926029' filename 'D:\GFI Languard Scan Results\Aug 2017\scanresultxml_Desktop Scan.txt_2017_08_03_145414.xml' result '-2'<<"
..."error ","Exporter","ExportScanResultsFromDatabase::ExportToXmlFile COM error HRESULT '-2147217871' メッセージ 'IDispatch error #3121' source 'Microsoft OLE DB Provider for SQL Server' 説明 'Timeout expired'."
環境
- GFI LanGuard
- Microsoft SQL 2005 以上 (Microsoft SQL Express 版を含む)
解決策
- GFI LanGuard のインストールフォルダーにある toolcfg_database.xml ファイルをバックアップしてください。
- ファイルをメモ帳で編集してください。
- 以下のセクションを探してください。
<Option Name="ScanHistory_RemoveOlderThanValue"><![CDATA[36]]></Option>
- </Option> タグの後に1行追加し、以下の2行を貼り付けてください。
<!-- Command timeout in seconds. -->
<Option Name="Timeout"><![CDATA[300]]></Option>
<Option Name="Timeout"><![CDATA[300]]></Option>
- ファイルに変更を保存してください
- GFI LanGuard アテンダントサービスを再起動し、GFI LanGuard コンソールを開いてください。
原因
Microsoft SQLサーバーは、ディスクやネットワークI/O、またはリソース不足が原因でタイムアウトすることがあります。