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Multiple GFI LanGuard Installations Logging to the Same SQL Database

Overview

In environments where multiple subnets, domains, or other circumstances create the need for multiple instances of GFI LanGuard, it is possible to configure these multiple instances to log into a single, central SQL database. This article provides the steps to set up two different scenarios for such a configuration.

Diagnosis

When installing the second LanGuard instance and configuring the backend database, which is already in use by another instance, the following configuration screen will appear:
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In order to allow both instances to log data into the same database, Create a new data session needs to be selected.

Note: If the first option, Take Ownership Of the Selected Data Session is selected, it causes the second instance to take ownership of the database, including its data sessions, and thereby disallowing the usage of this database by the first instance.

Once two or more instances are configured to work with the same backend database, there are two scenarios:

  1. Instances are able to read and write into the same database but only see their own scans and results; not the scans from the other LanGuard instances (fully supported scenario).
  2. All instances are able to read and write into the same database and see the same scan results from all the instances (unsupported scenario).

 Note: For multiple installations of GFI LanGuard to successfully log to the same Microsoft SQL database, it is important to ensure that all the installations are running the same version and build of GFI LanGuard.

Solution

Scenario#1

Each instance of GFI LanGuard is configured to view only their own scans and results. This scenario is Fully Supported by GFI LanGuard. This is the default behavior, and once Create a new data session is selected, no farther configuration changes required.

 

Scenario#2

By default, each GFI LanGuard instance has its own Installation ID, and every time a new scan is saved in the SQL database, it is linked with this Installation ID. Changing the Installation ID allows multiple GFI LanGuard instances to view the same scan results from all instances, but this scenario is Not Supported and Not Recommended

To configure multiple LanGuard instances to show all scan results:

  1. Install an Instance of GFI LanGuard and when a configuration screen above appears, choose the same option Create a new data session in order to allow all instances to log data into the same database.
  2. Make Installation ID of each Installation same:
    1. Edit the <Installation id=XXX> section of the file \Program Files (x86)\GFI\LanGuard 12 Agent\crmiini.xml.

    2. Enter the Installation ID.

    3. Enter the same Installation ID as entered in Step-2 by editing the above file on all the GFI LanGuard installations.

With the above change, all the new scans get saved in the database with the same Installation ID, and the same information is displayed on all the consoles.

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  1. Priyanka Bhotika

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