Overview
No new patches and definitions are downloaded. When running Program Update from the console the following error is displayed: 'Failed while checking for available updates. Update index file was not found or is not valid'
Diagnosis
The above error is usually caused by the proxy server settings or the network firewall blocking access to the GFI LanGuard update site.
Follow these steps to verify the access:
- On the GFI LanGuard server open the Services panel by going to Control Panel > System and Security > Administrative Tools > Services.
- Locate the GFI LanGuard 12 Attendant service, double click on it, and select the Log on tab. Notice the account specified to start the service.
- If you are not currently logged in under this account, log out and log in back with the same credentials as being used by the GFI LanGuard Attendant service.
- Open the Windows Explorer browser and attempt to access the LanGuard update site directly to download the file http://lnsupdate.gfi.com/lnsupdate/index.txt.
If it fails to download, it means that the access to the LanGuard update site is indeed blocked.
Solution
Depending on the exact environment, there can be various possible reasons for access to the web site to be blocked. Check the most common ones:
- Verify whether the connection is going through a proxy server, either with your system administrator or by visiting one of the available proxy detection websites, for example, http://www.whatismyproxy.com/. If there is a proxy - open GFI LanGuard console and enter proxy details under Configuration > Program Updates > Edit proxy settings.
- Verify whether the connection is being blocked by your server firewall - you should receive an access denied message. There should be corresponding records in the firewall logs that the connection is being blocked. Remedy this according to your environment and software.
- Verify with network administrators whether there is a network firewall blocking the access and how to unblock it.
In order to verify if the root cause is eliminated, you can repeat the Diagnosis steps. Under normal conditions, the browser should display a page with a single number in it when accessing http://lnsupdate.gfi.com/lnsupdate/index.txt, for example:
Testing
Once the access is restored perform a manual update to ensure that updates are downloaded without errors. If the issue persists contact the Support Team.
Priyanka Bhotika
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